LevelOne Manual

Main Window

The Main Window shows a list of all files imported and (soon to be) analyzed files. You can add files by clicking the folder icon, select “Add file(s)” from the file menu or press <cmd-o> on mac or <ctrl-o> on pc. The easiest way is to drag files from your computer into the list area.

You can also drag folders to the list. If you do so all audio files in the folder and it’s subfolder will be added to the list. The folder structure will be kept intact.

Supported file formats are wav, bwf, aiff, sd2 and flac in stereo, 5.0 and 5.1 surround. Surround audio can be in single (multichannel) file format or multiple mono files. In the latter case, make sure the files have the right labeling:

Channelfilename wavfilename aiff
left channelfilename.l.wavfilename.l.aif
right channelfilename.r.wavfilename.r.aif
center channelfilename.c.wavfilename.c.aif
LFE channelfilename.lf.wavfilename.lf.aif
left surround channelfilename.ls.wavfilename.ls.aif
right surround channelfilename.rs.wavfilename.rs.aif

LevelOne supports RIFF64 to accomodate for files larger than 4 GB.


The file list

In the first column the status of the file is indicated. During analysis and exporting it shows a small spinner indicating how much of the file is analysed or processed. When exporting fails it will display an exclamation mark. The file name is in the second column or, if selected in the preset, first the source folder of the file is indicated. Dependent on the preset settings, one or more of the following measurements will be on display in the subsequent columns:

  • LUFS: the Loudness Units level, relative to Full Scale
  • LU: the relative Loudness Units level, calibrated in the preset.
  • max M: the maximum Momentary loudness, measured with 400ms window.
  • LRA: the Loudness Range, based upon a statistical distribution of the Short term measurement.
  • max S: the maximum Short term loudness, measured with 3s window.
  • max PPM: the maximum Peak Program Meter level, calibrated in the preset.
  • max Sample Peak: the old style peak level, based upon maximum sample values.
  • max True Peak: the interpolated True Peak level.
  • Adjust: the amount of dB the file has been or must be adjusted for normalisation according the preset target level settings.
  • Most right, one has the option to view all kinds of file info such as file type, length, size, amount of channels, bit rate, sample rate, date. This information is also available via the File Inspector (see the File Inspector section).

For the LU, max M, max S, LRA, PPM and True Peak columns a warning threshold can be set in the preset editor (read the Warnings section under Presets). Warnings will be displayed as exclamation marks in the column that asks for your attention.

Because of the 3 seconds window length, the LRA and max S calculation of short files has limited value. For files shorter than 10 seconds, ‘NA’ is displayed in the LRA column; for files shorter than 3 seconds ‘NA’ is displayed in the max S column.

Post adjust view

After analysis one can toggle between pre and post view by using the ‘Post adjust view’ option in the ‘file’ menu or by pressing the key. When toggled the file list will show the LU, PPM and Peak values after the calculated adjustment is applied.


Selecting

A file can be selected by clicking on it. Using the key one can select a row of files at once. Use the key on windows or the key on mac to (de)select multiple files by clicking each file. The up/down arrows, home/end and the page-up/down buttons are also available for those who don’t like mice. Files can be removed from the list by clicking the remove button, selecting “Remove file(s)” from the file menu or pressing the backspace (mac) or del (pc) key.

Sorting

To sort the result in the table click the column title of the column you would like to sort. By clicking it once more you can switch between an ascending and descending order.

File inspector

The list in the Main Window displays the most important information on the file. To view more details, select the file(s) from the list you would like to inspect, then select “File Inspector” in the file menu, click the File Inspector button in the list header, or press <cmd-i> on mac or <ctrl-i> on windows. For more information about the Inspector see the Inspector chapter of this manual.

Presets

Below the file list at the bottom of the Main Window, there is a drop down menu with presets. One can edit and create presets by selecting “” at the bottom of the list. For more information about the presets see the Presets section.

Analyse/Process

Depending on the preset the button next to the preset list is called “Analyse” or “Process”. Analyse means the file will be analysed only. Process means the files will be analysed, adjusted and exported.


Progress bar

At the very bottom of the Main Window you will find a progress bar. It will show you the overall progress of the total task of all files to be analysed or processed.

Export Data

In the ‘File’ menu you will find an option to save the results from the file list and inspector as a csv file (comma separated values). The data can be used within a spreadsheet program for further examination.

File inspector Window

The File inspector shows all kinds of file details. One can select a file and then open the Inspector, but it is also possible to select a different file when the inspector is opened. The Inspector can show information of one file or information of a collection of files.

The file details presented by the inspector are:

  • Name: the file name
  • Folder: the folder where the file is located
  • Length: the duration of the file in hours:minutes:seconds
  • Size: the file size in MB
  • Date: the creation date of the file
  • Format: the type of the file (Wav, Aif, etc)
  • Sub format: word length, encoding structure
  • Channels: number of channels in the file
  • Sample rate: Samplerate in Hz
  • LUFS: the Loudness Units level, relative to Full Scale
  • LU: the relative Loudness Units level of the file
  • Maximum M: the maximum Momentary loudness, measured with 400ms window.
  • LRA: the Loudness Range, based upon a statistical distribution of the Short term measurement.
  • Maximum S: the maximum Short term loudness, measured with 3s window.
  • Maximum PPM: the maximum Peak Program Meter level of the file.
  • Maximum Sample Peak: the maximum sample peak value of the file.
  • Maximum True Peak: the maximum true peak value of the file.
  • In the bottom table the PPM, Sample Peak and True Peak levels of the separate channels of the file are indicated.

When multiple files are selected the file details in the Inspector are:

  • Name: the number of files selected
  • Folder: the folder where the files are located or “-” if there’s multiple folders of origin
  • Length: total length of all files in hours:minutes:seconds
  • Size: total size of all files in MB
  • Date: first and last creation dates of the files
  • Format: the type of the file (Wav, Aif etc) or “mixed” when multiple formats
  • Sub format: word length, encoding structure or “-” for multiple sub formats
  • Channels: number of channels in the file or “-” if multiple formats
  • Sample rate: Samplerate in Hz or “-” if multiple samplerates
  • All other measurements are comparable to the situation above with just one selected file, except the levels are calculated for the combined files.

Selecting more than one file will display the approximate LU level of the combined files in the inspector. When the gate is enabled the Loudness Units level of the combined files will be an estimate as the gate for each file is set individually. When the gate is disabled the LU level of the combined files is precise.

Presets Window

All settings of the application are stored in presets. These presets can be created and recalled by the user, allowing fast and easy switching between settings for common normalization tasks. LevelOne has a set of factory presets that cover the most common jobs. They can not be editted, but one can create new presets based upon the factory version. If the factory preset is redundant it can be deleted (mark however that an update procedure will put the factory presets back in place). The factory presets are:

  • ATSC A/85 2009 Dialog Intelligence [analyze]
  • ATSC A/85 2009 Dialog Intelligence [process]
  • ATSC A/85 2009 [analyze]
  • ATSC A/85 2009 [process]
  • EBU PPM [analyse]
  • EBU R.128 mode [analyse]
  • EBU R.128 mode [process]
  • EBU R.128 max 8 M warning [analyse]
  • EBU R.128 max 8 M warning [process]
  • EBU R.128 max 20 LRA warning [analyse]
  • EBU R.128 max 20 LRA warning [process]

One can easily make a new preset by using an existing preset as a template. Do this by selecting this preset from the list in the ‘Edit presets’ dialog. Then click the ‘New’ button. A new preset will be created that contains the same settings as the selected template preset.

A preset can be edited by double clicking its name in the list or by selecting the preset and clicking on the edit button.

Create preset droplet/shortcut

A droplet/shortcut allows you to quickly process files. When files are dropped on it LevelOne will automatically add and start processing the file without any further action needed. To create a droplet from any preset go to the ‘Configure presets’ window, select your preset from the list and click ‘Create droplet’. The droplet will be created on the desktop, you can move it to any desired location on the computer.


General

Preset name

The name of the preset. Please note you cannot overwrite the default preset names.

Peak Measurement

Digital processing of all kinds is abundant nowadays. Some of these processes introduce regular digital peaks that are higher than the peaks of a 0 dBFS digital sine wave, when converted to analogue signals. These will make DA converters like in CD players and media systems clip in unpredictable manner and distort the sound. Similar clipping occurs in sample rate converters and lossy codecs like MP3. To avoid this problem, LevelOne uses an oversampling algorithm that emulates the filters used in these converters and thus is able to measure the True Peak level of the file. The oversampling algorithm is cpu intensive and therefore analyzing with enabled oversampling leads to longer processing times.

There are three choices for peak measurement in LevelOne:
* Sample Peak: will show the maximum sample values. This is the digital peak level as indicated by the majority of digital audio systems. The calculation of this peak level is very fast, but only recommended when you are certain there is enough headroom.
* True Peak Standard (BS.1770): will show True Peak levels using oversampling, conform the ITU BS.1770 “dBTP” standard. This is the recommended setting for normal use.
* True Peak Double Precision: will measure peaks at the highest precision, but with largely increased processing time. This setting is recommended when normalizing heavily processed signals to the maximum level (0 dB).

Oversampling


Loudness

Here you can choose whether you want to use the relative ‘LU’ or the absolute ‘LUFS’ scale for your display. In the tab “Calibration” you can select the 0 LU reference level.

LUFS Gate

Switch on/off the ‘ITU BS-1770-2 background sound gate’ for the LUFS measurement. The EBU R128, ITU BS.1770-2 and -3 loudness normalization standards incorporate the use of a gate that pauses the measurement when the audio program falls below a certain level (10 dB below the ungated LUFS loudness value) for longer than 400 ms. The purpose of this is to avoid ‘silent’ movies with lots of low level fragments to measure relatively low and thus inadvertently receive a gain that provides too high foreground sound levels. If the normalization has to comply with R.128 the gate should be engaged. It is advised to use the gate in almost every situation, except perhaps when normalizing classical music where the silent parts do not play a background but a foreground role.

Calculate Voice Level

By selecting this option LevelOne will run a proprietary Dolby algorithm called ‘Dialog Intelligence’ when analysing the files. Dialog Intelligence features an algorithm that recognices voice, which is arguably the most important anchor element in a movie. The algorithm opens the measurement gate when it recognizes speech, so that only audio that includes voice sounds is integrated. Of course automatic recognition is not flawless, it will show false positives and false negatives. Also dialog usually does not sit at just one level. So the measurement result is the average level of the fragments that were recognized as speech.

LevelOne can show and use the following aspects of the Dialog Intelligence algorithm in the View and Target (warning) tabs:

  • Voice Level. The average level of the fragments recognized as speech.
  • Dialog %. The percentage of the file that was recognized as speech. If this drops below 10 to 15%, it is advised to perform a manual check of the voice level.
  • I-VL delta. This measure shows the difference between the Program Level (or ‘I’ level) of a file and its Voice Level. When using EBU R128 normalization, these levels should not be too far apart. Commercials usually have their dialog close to program level and when a movie is interrupted by a commecial block a subjective loudness jump can occur if the I-VL delta is larger than 3 to 4 LU. Consider dynamic treatment of the movie in that case.

ATSC A/85 prescribes to use the dialog level for normalizing audio and Dialog Intelligence can be used to perform this task automatically. Mark that ATSC recommends to perform a manual analysis where possible, for instance by isolating a dialog stem during mixing. The 2009 A/85 document did not advice the background sound gate of the former ‘LUFS Gate’ paragraph. If you have access to isolated voice files, LevelOne can be used for this analysis.

Mark that when the Dialog Intelligence option is enabled, CPU power demand during analysis is increased slightly.


Surround channel order

The LUFS measurement has a different weighting for the surround speakers. Therefore LevelOne must know the channel order of multichannel files in your facility. There are three options:

  • SMPTE/ITU (L-R-C-Lfe-Ls-Rs)
  • Film (L-C-R-Ls-Rs-Lfe)
  • DTS (L-R-Ls-Rs-C-Lfe)

View

In the View tab the various column types to be on display can be selected.

Calibration

Reference level calibration

Both LU and PPM have to be calibrated to a certain level. EBU recommendations prescribe 0 PPM to equal -9 dBFS and 0 LU to equal -23 LUFS.

Target

Target level (adjust)

LevelOne is able to automatically normalize files and save them in a new folder. To control the normalization process a target level must be set. There are three options:

  • LU or LUFS: targeting a LU level, for example 0 LU according to the EBU R.128 Recommendation. This field shows LU or LUFS, dependent on the selection in the General tab.
  • PPM: targeting a PPM level, for example 0 PPM according to the “old” EBU Recommendations
  • Peak: targeting a True Peak or sample peak level, depending on the selected algorithm in the preset:
    • dBFS: sample peak, using no oversampling. This is traditionally referred to as “normalizing”. We discourage to use 0 dBFS as a target level because signals may clip during conversion to the analogue domain.
    • dBTP: True Peak. This is recommended as a replacement for “traditional” normalization as this will still normalize using peaks but calculates the headroom needed for interpolation.
  • Voice Level: when Dialog Intelligence is enabled in the General tab, a Voice Level can be used as target.

Notify when finished processing

If this option is set, a sound will be played when all selected files are processed.

On Mac OSX LevelOne supports Growl notifications, even when the ‘Notify’ option is not selected. Settings for the Growl notifications can be found in the system preferences under Growl. For more information about Growl visit http://growl.info/.

Warn when exceeding levels after adjustment

Use this option to warn when a certain level is exceeded. An exclamation mark will be shown in the column that exceeds the prescribed level. It is possible to set warnings for each measurement method separately. The default warning levels have been set to numbers that some broadcasters have selected as a limit, such as max M = +8 LU for commercials and promos or max LRA = 20 LU for other program material. Default presets with these warnings are also available.

Note that LevelOne will never export at the target level if this means the peak levels of the file will exceed a 0 dB sample peak or True Peak level. If this situation occurs, LevelOne will use and display the maximum level it could reach (closest to the target level) and indicate an exclamation mark in the adjust column to draw your attention.

Export

This tab specifies if and how LevelOne exports copies of the files.

Export adjusted copy

When enabled the file will be adjusted and saved to a new location. The original file will stay intact. When exporting is disabled the Main Window will display a button called “Analyse” as files will be measured only. When exporting is enabled, the Main Window will display a button called “Process”, indicating that files will be measured, adjusted and saved.

From the main display, the current output folder can be revealed by selecting “Reveal current export folder” from the View menu, or by pressing the shortcut <alt-r>.

Export Settings

File name tag

You can automatically add a custom tag at the end of each exported file, indicating that the file has been processed and adjusted to the selected standard.

Output locations

Specifies in which folder the exported file(s) will be saved. Leave this field empty to overwrite the original files that will be processed with this preset. However, if a ‘File name tag’ is used the new file will be placed next to the original including the tag.

Replace existing files

This option selects if existing files will be replaced. There are three options:

  • Yes: replaces files without a warning.
  • No: skips existing files without a warning. Skipped files are indicated in the main screen, using an exclamation mark in the status column of the file.
  • Ask: LevelOne will ask you what to do for each file that already exists.

Word length

Specifies the word length used for the exported file. Files will be truncated with flat 2LSB TPDF dither.

There are three options:

  • 16 bit
  • 24 bit
  • original (this will export the new file using the word length of the original file)

Export PDF file with results

When this option is selected, a pdf file with the file name is placed next to the exported file. It contains all pre and post adjust analysis data of the file. This pdf can be used for later reference and is also beneficial when accessing the exported files from another computer in a networked environment. Mark that this function also works in “Analyse” mode (without exporting a normalized file). The indicated folder is then used just for the pdf.

Export as BWF v2 with EBU loudness metadata

BWF v2 of 2011 added loudness metadata to the bext (main) chunk of a BWF file. The following loudness metadata is defined: LUFS, max M, max S, LRA and max True Peak level. When a BWF file that has this metadata is imported into LevelOne, the stored values are shown in grey in their corresponding columns. When exporting a BWF format file, LevelOne will convert it to BWF v2 format and store the measured values in the metadata fields. The “Export as BWF v2 with EBU loudness metadata” option allows to convert files of any audio format (wav, aiff, sd2, flac) into BWF v2 format with loudness metadata.

Components

In this tab the file name tags are defined that instruct LevelOne about which file represents which channel in a component or ‘multiple mono’ file set. You can add extra tags if your preferred types are not listed. Please seperate the tags by a colon sign “:”.